零基础学炒股_股票入门基础知识_2GG股票学习网
股票学习第一门户网站 网站地图

网站首页 指标公式 同花顺公式 正文

同花顺公式之四度空间(副图 源码)

2GG股票学习网 2020-01-27 同花顺公式 804 ℃ 0 评论

四度空间的参数如下

TYP := (HIGH + LOW + CLOSE)/3;
CC1:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M)),ColorFF00FF;
C1:=SMA(CC1,3,1);
C2:=SMA(C1,3,1);
C3:=3*C1-2*C2;
CB1:=EMA(C3,5);
CB2:=REF(CB1,1);
FILLRGN(CC1,100,CC1>100,RGB(50,225,50),CC1<-100,RGB(250,150,50));
STICKLINE(C>1,100,-100,100,0),colorblack;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI:(RSI1-50)*5,LINETHICK2,ColorFFFFFF;
R1:=SMA(RSI,3,1);
D1:=SMA(R1,3,1);
J1:=3*R1-2*D1;
RR1:=EMA(J1,5);
RR2:=REF(RR1,1);
RR:=RR1>RR2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
K1:(K-50)*5,ColorFFFF00;
K2:=SMA(K1,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
买入:RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,LINETHICK0;
DRAWICON(买入,-200,4),ALIGN0;
卖出:REF(RR,1)=1 AND NOT(RR) AND CB1>100,LINETHICK0;
DRAWICON(卖出,200,2),ALIGN0;
VAR1:=((CLOSE - LLV(LOW,15))/(HHV(HIGH,15) - LLV(LOW,15)))*(100);
VAR2:=REVERSE(VAR1);
VAR3:=SMA(VAR1,5,1);
K:=SMA(VAR3,3,1);
D:=SMA(K,3,1);
85,STICK,Linethick7,ColorFF0000;
DRAWTEXT(CROSS(K,D) AND (D < 18),15,'买'),Color00FF00;
DRAWTEXT(CROSS(D,K) AND (D > 75),85,'卖'),ColorFFFFFF;
STICKLINE((K >= D),K,D,6,0),Color0000A8;
STICKLINE((K >= D),K,D,5,0),Color0000C0;
STICKLINE((K >= D),K,D,4,0),Color0000E0;
STICKLINE((K >= D),K,D,3,0),Color0000F0;
STICKLINE((K >= D),K,D,2,0),Color0000D0;
STICKLINE((K >= D),K,D,1,0),Color8080FF;
STICKLINE((K <= D),K,D,6,0),Color008800;
STICKLINE((K <= D),K,D,5,0),Color009900;
STICKLINE((K <= D),K,D,4,0),Color00AA00;
STICKLINE((K <= D),K,D,3,0),Color00BB00;
STICKLINE((K <= D),K,D,2,0),Color00CC00;
STICKLINE((K <= D),K,D,1,0),Color00DD00;
M1 := EMA( CLOSE, 9 );//www.70822.com
M2 := EMA( CLOSE, 18 );
MD :  M1 - M2, colorwhite, LINETHICK3;
MM := EMA( MD, 3 );
吸 : IF( MD >= MM AND MD <  0, MD, DRAWNULL ), colorlired, LINETHICK3;
拉 : IF( MD >= MM AND MD >= 0, MD, DRAWNULL ), colorred,   LINETHICK3;
派 : IF( MD <  MM AND MD >= 0, MD, DRAWNULL ), colorgreen, LINETHICK3;
落 : IF( MD <  MM AND MD <  0, MD, DRAWNULL ), colorwhite, LINETHICK3;
diff:=EMA(C,12)-EMA(C,26);
dea:=EMA(diff,9);
第一红:CROSS(diff,dea);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
蓝:IF(FILTER(YXF=1,5),20,0),colorliblue,LINETHICK3;
红:  IF(FILTER(YXF=1,5),10,0),colorred,LINETHICK2;
黄: IF(FILTER(YXF=1,5),5,0),coloryellow,LINETHICK1;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD上拐:REF(DEA,2)>REF(DEA,1) AND REF(DEA,1)<DEA;
过渡:IF(BBI,10,DRAWNULL),colorwhite,LINETHICK2;
持股:IF(C>BBI AND BBI>REF(BBI,1),10,DRAWNULL), colorred,LINETHICK2;
持币:IF(C<=BBI AND BBI<=REF(BBI,1),10,DRAWNULL),colorgreen,LINETHICK2;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
出击:CROSS(阶段底部,0);
diff:=EMA(C,12)-EMA(C,26);
dea:=EMA(diff,9);
第一红:CROSS(diff,dea);
选股:CROSS(MACD>0,0.5);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
蓝:IF(FILTER(YXF=1,5),20,0),colorliblue,LINETHICK3;
红:  IF(FILTER(YXF=1,5),10,0),colorred,LINETHICK2;
黄: IF(FILTER(YXF=1,5),5,0),coloryellow,LINETHICK1;
DIF3:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA3:=EMA(DIF3,9);
MACD3 := 2*(DIF3-DEA3);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
止跌:MACD3>REF(MACD3,1) AND REF(MACD3,2)>=REF(MACD3,1)  AND J<50 AND  C>REF(C,1) AND C>O AND J>REF(J,1);
A1:=REF(C,1);
A2:=DCLOSE;
A3:=(A2-A1)/A1*100;
AA1:=(A3-REF(A3,1));
AA2:=9.8;
选股1:=CROSS(AA1,AA2);
A11:=REF(V,1);
A12:=DVOL;
A13:=A12/A11;
AA3:=(A13-REF(A13,1));
AA4:=500;
选股2:=CROSS(AA3,AA4);
主力抢劫:选股1 AND 选股2;
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5  AND GJTJ1>GJTJ4;
牛起涨:COUNT(XG,3)=1 AND XG;
Zero : 0;


Tags:同花顺公式

本文系由> 2GG股票学习网编辑和原创,假如需要转发本文,请务必在文本结尾注明来源!谢谢您的合作!

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

请填写验证码