零基础学炒股_股票入门基础知识_2GG股票学习网
股票学习第一门户网站 网站地图

网站首页 指标公式 通达信公式 正文

通达信公式之反弹主图(主图 源码)

2GG股票学习网 2020-04-07 通达信公式 26 ℃ 0 评论

MA5:MA(C,5),COLORFF00FF,LINETHICK1;

MA10:MA(C,10),COLOR00FFFF,LINETHICK1;
MA21:MA(C,21),COLORC0FF7F,LINETHICK1;
MA55:MA(C,55),COLORFFFFFF,LINETHICK1;
MA89:MA(CLOSE,89),COLORYELLOW;
长线:MAX(MA(CLOSE,60),MAX(MA(CLOSE,120),MA(CLOSE,250))),COLOR555B44;
三百底涨:(CLOSE-LLV(CLOSE,300))*100/LLV(CLOSE,300),NODRAW,COLORRED;
三百高跌:(CLOSE-HHV(CLOSE,300))*100/HHV(CLOSE,300),NODRAW,COLORGREEN;
VAR1:=1;
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
X_1:=1.2*LLV(CLOSE,300);
STICKLINE(CLOSE<X_1 AND CLOSE>=OPEN,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(CLOSE<X_1 AND CLOSE>=OPEN,LOW,HIGH,0.5,0),COLORGREEN;
C1:=(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1),COLORRED,LINETHICK2;
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1),COLORFFFFFF,LINETHICK2;
X_2:=1.5*LLV(CLOSE,300);
STICKLINE(RANGE(CLOSE,X_1,X_2) AND CLOSE>=OPEN,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(RANGE(CLOSE,X_1,X_2) AND CLOSE>=OPEN,LOW,HIGH,0.5,0),COLORRED;
AA:=C1>=C2 ;
BB:=C2>C1 ;
DRAWICON(CROSS(C1,C2),L-0.1,1);
DRAWICON(CROSS(C2,C1),H+0.1,2);
X_3:=1.8*LLV(CLOSE,300);
STICKLINE(RANGE(CLOSE,X_2,X_3) AND CLOSE>=OPEN,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(RANGE(CLOSE,X_2,X_3) AND CLOSE>=OPEN,LOW,HIGH,0.5,0),COLORMAGENTA;
STICKLINE(AA,C,O,2,0),COLORRED;
STICKLINE(AA,H,L,0.5,0),COLORRED;
STICKLINE(BB,C,O,2,0),COLOR00FF00;
STICKLINE(BB,H,L,0.5,0),COLOR00FF00;
STICKLINE(AA,CLOSE,OPEN,2.5,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR0000CC;
X_4:=REF(CLOSE,1);
X_5:=IF((CLOSE-X_4)*100/X_4>=10-0.01*100/X_4,1,0);
STICKLINE(X_5,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(BB,CLOSE,OPEN,2.5,0),COLORFF7700;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORCYAN;
DRAWTEXT(CROSS(CLOSE,X_1),X_1,15),COLORYELLOW;
DRAWTEXT(CROSS(CLOSE,X_2),X_2,16),COLORYELLOW;
DRAWTEXT(CROSS(CLOSE,X_3),X_3,17),COLORYELLOW;
DRAWTEXT(CROSS(CLOSE,2*LLV(CLOSE,300)),2*LLV(CLOSE,300),18),COLORYELLOW;


Tags:通达信公式主图源码

本文系由> 2GG股票学习网编辑和原创,假如需要转发本文,请务必在文本结尾注明来源!谢谢您的合作!

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

请填写验证码